supersaver

Author Topic: Error when trying to edit post.  (Read 170 times)

Offline Marve

Error when trying to edit post.
«: April 06, 2017, 07:49:37 PM»
I'm trying to edit my original alt selling post to edit some prices, but whenever I press save it brings me to a blank page with this error message:

"Forbidden

You don't have permission to access /index.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

Not sure what this is and never seen it before.


Edit: When editing this post, it allows me to do so. Just not my selling thread.


Offline Zim

Re: Error when trying to edit post.
«Reply #1: April 06, 2017, 08:46:29 PM»
As noted here, we have no idea what causes this except it's very likely on SMF's end, not ours.

We suggest:

- Trying an alternate browser
- Clearing your cache/cookies

It seems like what triggers it (if it's the same cause as before) is links in the body of the message you're trying to edit. Unfortunately, we never found a solid fix for it, since it's so random on when/who it hits and there's no way to reliably replicate it.

I'm only mean out of necessity.

Offline Cougar

Re: Error when trying to edit post.
«Reply #2: April 06, 2017, 09:24:28 PM»
I just so happened to start having this problem again tonight with my alt sales thread, and noticed another user reporting the same issue in short succession so adding my notes. Tried clearing everything and restarting browser with all add-ons disabled but no dice. Will try editing this post here in a sec.

Edit: Yep!

I'll keep tinkering with my sale thread. I was trying to remove three listed alt names with no other edits but no dice. I've now tried editing the post and saving without making any changes, and also no dice. For the time being, I'll just keep a running list of what all I haven't been able to remove.

Edit #2: Tried saving the post with no URLs to no avail. I was tempted to try saving a single word length edit but was afraid of getting stuck that way!
« Last Edit: April 07, 2017, 01:37:24 AM by Cougar »
An Astonishing Armada of Awesome Alts, All Available for ASAP Acquisition!
No price listed in the main post? Hit me up with $5 and we've got a DEAL!

Offline Marve

Re: Error when trying to edit post.
«Reply #3: April 07, 2017, 11:54:00 AM»
I cleared my cache and cookie data, it's letting me edit now no problem. (I probably needed to do that anyway.)

For future reference, I use Chrome

Offline Cougar

Re: Error when trying to edit post.
«Reply #4: April 07, 2017, 10:06:45 PM»
Just tried on my phone using Chrome (I use Firefox on PC) and no dice. I clear everything on Chrome on a regular basis and to my knowledge have never visited this website on this phone, so it's looking like there's nothing I can do on my end.

Edit: Editing on Chrome to "Ok" did the trick and saved the edit, as opposed to the previous attempt where I just loaded the modify page and tried to click "Save" with no actual edits. Checked in Firefox and same. Adding in bits line by line in Firefox now to find the culprit.

Edit #2: It hinges around between line 4239 and 4240 in my sale post, the alts Get and Gig. Posting only up to Get works, adding in Gig doesn't. Acting on a hunch that "Gig" became disallowed, I removed it from my list and tried again, no dice. I then tried to post just one letter on the newline after the alt Get, no dice. A space after "Get," no dice.

Edit #3: Removing "Get" allowed me to continue saving line by line. Keeping on testing.

Edit #4: The next hang was at the alt "Move" and removing it allowed me to continue.

Edit #5: And predictably the next hang was at the alt "Put." I'm sensing a trend. Put by itself works. Put with a newline or space after it does not. In this "Questions and Support" thread, editing the current post to add in the line "Get Move Put" works fine, but the moment I put any of those on a line by themselves (whitespace notwithstanding), it 403s. As I've had Get in my alt sale post since 2012, Move since 2013, and Put since 2014, it looks like they just implemented some type of security feature. "It's not a bug, it's a feature!" Those were the only three in my thread, and having removed them I've been able to re-add the rest of my post.

As a workaround I've changed the three offending lines to include a price.
« Last Edit: April 07, 2017, 11:14:59 PM by Cougar »
An Astonishing Armada of Awesome Alts, All Available for ASAP Acquisition!
No price listed in the main post? Hit me up with $5 and we've got a DEAL!

Offline Vinters

Re: Error when trying to edit post.
«Reply #5: July 11, 2017, 02:50:43 PM»
I'm getting hit with this error message regardless of what post I'm on. I've trying clearing my cache, it worked once and then when it 403'd again, I tried clearing it again and it hasn't worked since.

edit: Surprised this made it through!

 

supersaver